Remove EME from Unsecure Contexts (removed)

Per https://w3c.github.io/webappsec-secure-contexts/, we are deprecating and then removing EME from insecure contexts. EME is a powerful feature that exposes DRM implementations that involve access to persistent unique identifiers, are not open source, and/or run unsandboxed or with privileged access. The risks are increased when exposed via insecure HTTP, because they could be attacked by anyone on the channel. This was deprecated in Chrome 44.

Documentation

Status in Chromium

Removed (launch bug) in:

  • Chrome for desktop release 58
  • Chrome for Android release 58
  • Android WebView release 58
  • Opera release 45
  • Opera for Android release 45

Consensus & Standardization

  • Public support
  • No public signals
  • No public signals
  • No signals

Owners

Last updated on 2017-04-25