Selection API: setBaseAndExtent(), extend(), and collapse() throw InvalidNodeTypeError for DOCTYPE

These function silently normalized the specified position with DOCTYPE. However, they should throw InvalidNodeTypeError to match to Edge, Firefox, and the specification.

Specification

Editor's draft

Status in Chromium

Blink>Editing>Selection


Enabled by default (launch bug) in:

  • Chrome for desktop release 58
  • Chrome for Android release 58
  • Android WebView release 58
  • Opera release 45
  • Opera for Android release 45

Consensus & Standardization

  • Shipped
  • Shipped
  • No public signals
  • No signals

Owner

Last updated on 2017-06-14